Jak si nastavit verzi PHP na svém hostingu?

Jednou z předností webhostingu (resp. mutlihostingu) u ACTIVE 24 je možnost flexibilního přepínání verzí PHP. Zákazník může tedy zvolit verzi PHP, jakou aktuálně potřebuje nebo má možnost testovat, jak se web chová na různých verzích PHP zcela bez vlivu na ostatní návštěvníky webu.

Doposud měly všechny naše hostingové servery v nabídce tři verze PHP a sice 5.3, 5.2 a 4.4. Servery ale pravidelně aktualizujeme a na tom posledním, kde se aktuálně zřizují nové virtuály, jsme verze obměnili tak, že bylo doplněno zbrusu nové PHP 5.4 a naopak jsme odstranili PHP 4.4.

Pokud si dnes objednáte (nebo v rámci již existujícího multihostingu zřídíte) nový virtuální server, bude na něm nastavena implicitní verze PHP 5.3. Tu lze ale prostřednictvím našeho Zákaznického centra snadno přepnout např. právě na PHP 5.4 a to v sekci Virtuální servery – ikonka brýlí:

Druhá možnost je ta, že verzi PHP nebudete rovnou přepínat, ale pouze se jednorázově podíváte, jak se váš web v jiné verzi chová, přičemž na ostatní návštěvníky vašich stránek to nebude mít žádný vliv. Hodí se to zejména ve chvíli, kdy se chystáte na změnu verze a chcete si předem bez rizika ověřit, jestli je váš web na změnu připraven a případně jej nejprve doladit. Uděláte to tak, že do URL doplníte za dvojtečku číslo portu, na kterém běží webserver s příslušnou verzí PHP. Tedy pokud např. na stránkách www.vasefirma.cz běží PHP 5.3 a vy se chcete podívat, jak by to vypadalo na verzi 5.4, stačí do prohlížeče zadat URL http://www.vasefirma.cz:84/
Momentálně využíváme porty 84, 85 a 86, přičemž jaká verze běží na kterém portu příslušného serveru zjistíte snadno tak, že si zobrazíte odpovídající phpinfo např. takto: http://uvirt25.active24.cz:84/info.php
Starou verzi 4.4, která již není podporovaná a běží na starších serverech, plánujeme postupně ukončit (zatím bez upřesnění termínu) a weby, které ji používají, převést na PHP 5.2. Běží-li váš web ještě na starém PHP 4.4, využijte tuto příležitost k otestování, že na verzi 5.2 případně 5.3 poběží stejně dobře a v Zákaznickém centru si ji následně přepněte.
Na našich virtuálních managed serverech (VMS) funguje vše výše zmíněné analogicky a pokud server nenabízí verzi PHP, kterou nabízíme jinde, stačí nám napsat, abychom ji doplnili. Ti náročnější z vás, kteří si objednají server VMS Premium Plus, mohou dokonce vyžadovat zcela individuální kompilaci PHP v libovolné verzi s libovolnými moduly.

NAPIŠTE KOMENTÁŘ